PGP encrypted subject line results in additional subject line on decryption

Hi everyone,

We are using the ciphermail Community edition and recently discovered the following issue.
When we receive an email which contains a PGP encrypted subject line it is properly decrypted (i.e. an additional subject header with the encrypted subject line is added to the email). However, the original placeholder like subject line which contains “…” remains in the email header. This leads to the problem that the email client (Thunderbird) uses the last subject header it finds for display, which happens to be the placeholder one with the “…”.
Therefore, my question would be, if ciphermail could remove the placeholder subject line during decryption (or change the order of the subject headers, so that the decrypted one is used)?

Kind regards,



Thanks for the bug report. We need some time to investigate this and see what the best solution is. Checking whether there is already a subject and replacing the subject should be doable. The main question however is whether this is safe. Should we replace any subject? or only a subject which is set to “…”?

A temp workaround for you might be to use a Postfix content filter to strip a subject which is set to “…”

Hi Martijn,

Thank you for the quick response!

I don’t know if it can differ (depending on the used client encrypting the email) how the placeholder subject line looks. We observed the subject line with “…” in the scenario where we are encrypting/decrypting mails with ciphermail and our communication partner is using Thunderbird’s integrated PGP functionality for that purposes.
I would argue that if an encrypted subject line is present this should replace whatever subject line has been set before when the email is decrypted (at least this seems logical to me as the email sender used one subject line when he sent the email and this should have to be the encrypted subject if such a subject is present).
If there are still doubts, maybe a configuration option where this behaviour can be enabled for specific users/domains would be an alternative?

Also thank you for the pointer to a possible workaround. I have no experience with Postfix content filters so far, but I will have a look at it.

Kind regards,