Webinterface Error

I installed Ciphermail on Ubuntu, at first it worked fine.
Then I did restore a backup file from the centos vm and I did a reboot.
Now I cannot get into the web interface it throws an error.

 A problem occurred
Error message:
Render queue error in BeginRender[Login]: Error invoking service builder method mitm.djigzo.web.services.SoapModule.buildGlobalPreferencesManagerWS(GlobalPreferencesManagerWSProxyFactory, ApplicationStateManager) (at SoapModule.java:813) (for service 'GlobalPreferencesManagerWS'): org.apache.cxf.service.factory.ServiceConstructionException: Failed to create service.
Click here to continue
Contact your administrator if this condition persists

Has anyone an idea what the problem might be?
Thanks for your help in advance.

Does the back-end startup without errors?

Can you check the back-end log and post the relevant lines if there are errors/exceptions.

Hello Martijn,
thank you for your quick answer.
the relevant info message might have been:

[2023-10-18 09:07:08] [info] 09:07:08.123 [https-jsse-nio-8443-exec-7] ERROR org.apache.tapestry5.internal.services.InternalModule.PagePool - Page Page[Login en] is dirty, and will be discarded (rather than returned to the page pool).

But I solved the problem another way, I restored a snapshot and transferred the config manually.
That worked for me. I won’t be importing centos based backups on ubuntu any more.

But I do have another problem now. I do not find anything in the documentation how to

  • automatically download pgp keys
  • automatically import pgp keys
    I would expect that there is a possibility to send e-mails and if there should be a public key on the keyserver ciphermail to use that key to encrypt…

How I came by this idea is via https://www.ciphermail.info/pdf/Ciphermail-Appliance-Prospekt.pdf

  • Automatischer Import von Schlüsseln und Zertifikaten,
  • Automatische Download von PGP-Keys und Validierung

Is that only available for paying customers?

so for example I got this in an e-mail:

X-Djigzo-Info-PGP-Signature-Failure: Signer's key with key ID CBE4568CE94EB45A
 not found.

The ID is available on the public key server and will be found (I did change the id for privacy means in my post). Why is cipher mail not downloading and importing it. Can this be changed, and how?

The main issue with auto import of PGP keys is that PGP keys cannot be trusted by default because anyone can create a PGP key with any email address.

Key servers allowed any key to be imported into the key server and therefore you could not automatically trust the key which was downloaded from the key server.

That said, recent key servers will now only accept the key if the email address was validated. So it might be a good idea to add an option to auto download a key and trust it.

I’ll put it on the development agenda.