Import of p7b files fails

I just got a phone call from a company using Ciphermail. They installed the current Ciphermail on a Debian 10 and tried to import a 180 MB backup, using Windows and Edge.

The reason why they called us ist, that they received the same error message as we did.

I doubt, that the problem is related to the size, because our backup has a size of only 22 MB and the p7b file only has 37KB.

Kind regards,



----Ursprüngliche Nachricht-----

Von: Martijn Brinkers <martijn(a)>
Gesendet: Montag 23. August 2021 6:50
An: users(a)
CC: Stefan Michael Guenther <s.guenther(a)>
Betreff: Re: Import of p7b files fails

On Fri, 2021-08-13 at 14:17 +0000, Stefan Günther via Users wrote:
> Hello,
> I setup Ciphermail 5.0.4 on Ubuntu 20.4 with Tomcat 9.0.31 and
> openjdk 11.0.11
> Importing a certificate from the current (old) Ciphermail is no
> problem. But when I select more than one certificate, the file
> certificates.p7b is created (which is technically okay) and the
> import fails with the message " There was an error uploading the
> certificate file. Cause: Processing of multipart/form-data request
> failed. Stream ended unexpectedly "

I just tested this is on a fresh installation of CipherMail on Ubutnu
20.04 and it works for me.

Which browser are you using?