# Upgrade error

**URL:** <https://community.ciphermail.com/t/upgrade-error/572>\
**Category:** Gateway\
**Created:** [August 26, 2017, 10:39pm UTC](https://community.ciphermail.com/t/upgrade-error/572 "2017-08-26T22:39:23Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Arie\_Koppelaar](https://avatars.discourse-cdn.com/v4/letter/a/e19adc/32.png) [@Arie\_Koppelaar](https://community.ciphermail.com/u/Arie_Koppelaar)\
**Post date:** [August 26, 2017, 10:39pm UTC](https://community.ciphermail.com/t/upgrade-error/572/1 "2017-08-26T22:39:23Z")

</div>

After upgrading from 3.1.1 to 3.2.7 a couple of things went wrong.  
- From the webinterface menu: Admin/MTA/config - The following error  
appeared:  
An unexpected application exception has occurred.

Render queue error in  
BeforeRenderTemplate[admin/mta/Config:relaydomains]: Failure reading  
parameter 'model' of component admin/mta/Config:relaydomains:  
ProcessException: Error running  
[/usr/share/djigzo/scripts/execute-script.sh,postfix-main-config,-g].  
exit value: 1 (1), Class: class mitm.common.util.ProcessException

- When restarting postfix from the Bash shell, the following error  
appears:  
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter:  
djigzo\_after\_filter\_message\_size\_limit=512000000

---

<div class="post-metadata">

**Author:** ![martijn](https://dub1.discourse-cdn.com/flex017/user_avatar/community.ciphermail.com/martijn/32/127_2.png) [@martijn](https://community.ciphermail.com/u/martijn)\
**Post date:** [August 27, 2017, 4:14pm UTC](https://community.ciphermail.com/t/upgrade-error/572/2 "2017-08-27T16:14:59Z")

</div>

> After upgrading from 3.1.1 to 3.2.7 a couple of things went wrong.  
> - From the webinterface menu: Admin/MTA/config - The following error  
> appeared:  
> An unexpected application exception has occurred.
> 
> Render queue error in  
> BeforeRenderTemplate[admin/mta/Config:relaydomains]: Failure reading  
> parameter 'model' of component admin/mta/Config:relaydomains:  
> ProcessException: Error running  
> [/usr/share/djigzo/scripts/execute-script.sh,postfix-main-config,-g].  
> exit value: 1 (1), Class: class mitm.common.util.ProcessException

This error is shown when the script cannot be executed. This might be  
cause by some sudoers issue or a script which cannot be executed or some  
config file which cannot be loaded

Try to execute the following command

sudo -u djigzo /usr/share/djigzo/scripts/execute-script.sh  
postfix-main-config -g

It should only ask for your password (for sudo) and not for the password  
of the djigzo user. The command should return the postfix main config  
file and execute without any errors.

> - When restarting postfix from the Bash shell, the following error appears:  
> /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter:  
> djigzo\_after\_filter\_message\_size\_limit=512000000

This is a warning from Postfix. In a default CipherMail Postfix config  
this parameter should be used. The warning is just a warning. Postfix  
should still be able to run. It could be that you modified the main  
config and that this parameter is not used (hence the warning). Can you  
show you postfix main config?

Kind regards,

Martijn Brinkers

> **···**
>
> On 27-08-17 00:39, Arie Koppelaar via Users wrote:
> 
> --  
> CipherMail email encryption
> 
> Email encryption with support for S/MIME, OpenPGP, PDF encryption and  
> secure webmail pull.
> 
> > **[CipherMail email encryption and digital signatures](https://www.ciphermail.com)**
> >
> > Easy to use server-side email encryption for automatic encryption and digital signing of email.
> 
> Twitter: [http://twitter.com/CipherMail](http://twitter.com/CipherMail)

---

<div class="post-metadata">

**Author:** ![Arie\_Koppelaar](https://avatars.discourse-cdn.com/v4/letter/a/e19adc/32.png) [@Arie\_Koppelaar](https://community.ciphermail.com/u/Arie_Koppelaar)\
**Post date:** [August 27, 2017, 4:37pm UTC](https://community.ciphermail.com/t/upgrade-error/572/3 "2017-08-27T16:37:33Z")

</div>

Thanks for your reply. Your remark about the sudo rights was spot on.  
For some reason the file /etc/sudoer.d/ciphermail was lost during the  
upgrade. After recreating it, the problem was solved.

Here's the first part of the mail.conf, presuming that the info you  
need.

# setting starting with djigzo\_ will be overwritten when applying the  
MTA settings  
djigzo\_myhostname = ciphermail.example.com  
djigzo\_mydestination =  
djigzo\_mynetworks = 192.168.1.0/24  
djigzo\_relayhost = mail2.example.com  
djigzo\_relayhost\_mx\_lookup =  
djigzo\_relayhost\_port = 25  
djigzo\_relay\_domains = example.com, example.nl, example.net  
djigzo\_before\_filter\_message\_size\_limit = 102400000  
djigzo\_after\_filter\_message\_size\_limit = 512000000  
djigzo\_mailbox\_size\_limit = 512000000  
djigzo\_smtp\_helo\_name =  
djigzo\_relay\_transport\_host = mail.example.com  
djigzo\_relay\_transport\_host\_mx\_lookup =  
djigzo\_relay\_transport\_host\_port = 25  
djigzo\_reject\_unverified\_recipient =  
djigzo\_unverified\_recipient\_reject\_code = 450  
djigzo\_parent\_domain\_matches\_subdomains =  
djigzo\_rbl\_clients =

> **···**
>
> ---  
> Groetjes,
> 
> Arie
> 
> Martijn Brinkers via Users schreef op 27-08-2017 18:14:
> 
> > On 27-08-17 00:39, Arie Koppelaar via Users wrote:
> > 
> > > After upgrading from 3.1.1 to 3.2.7 a couple of things went wrong.  
> > > - From the webinterface menu: Admin/MTA/config - The following error  
> > > appeared:  
> > > An unexpected application exception has occurred.
> > > 
> > > Render queue error in  
> > > BeforeRenderTemplate[admin/mta/Config:relaydomains]: Failure reading  
> > > parameter 'model' of component admin/mta/Config:relaydomains:  
> > > ProcessException: Error running  
> > > [/usr/share/djigzo/scripts/execute-script.sh,postfix-main-config,-g].  
> > > exit value: 1 (1), Class: class mitm.common.util.ProcessException
> > 
> > This error is shown when the script cannot be executed. This might be  
> > cause by some sudoers issue or a script which cannot be executed or  
> > some config file which cannot be loaded
> > 
> > Try to execute the following command
> > 
> > sudo -u djigzo /usr/share/djigzo/scripts/execute-script.sh  
> > postfix-main-config -g
> > 
> > It should only ask for your password (for sudo) and not for the  
> > password of the djigzo user. The command should return the postfix  
> > main config file and execute without any errors.
> > 
> > > - When restarting postfix from the Bash shell, the following error  
> > > appears:  
> > > /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter:  
> > > djigzo\_after\_filter\_message\_size\_limit=512000000
> > 
> > This is a warning from Postfix. In a default CipherMail Postfix config  
> > this parameter should be used. The warning is just a warning. Postfix  
> > should still be able to run. It could be that you modified the main  
> > config and that this parameter is not used (hence the warning). Can  
> > you show you postfix main config?
> > 
> > Kind regards,
> > 
> > Martijn Brinkers

---

<div class="post-metadata">

**Author:** ![Arie\_Koppelaar](https://avatars.discourse-cdn.com/v4/letter/a/e19adc/32.png) [@Arie\_Koppelaar](https://community.ciphermail.com/u/Arie_Koppelaar)\
**Post date:** [August 28, 2017, 7:14pm UTC](https://community.ciphermail.com/t/upgrade-error/572/4 "2017-08-28T19:14:53Z")

</div>

The difference turned out to be the rule (in the latest appliance  
version):  
message\_size\_limit = ${djigzo\_after\_filter\_message\_size\_limit}  
of the file main.cf, rule 71

Arie Koppelaar via Users schreef op 27-08-2017 18:37:

> **···**
>
> > Thanks for your reply. Your remark about the sudo rights was spot on.  
> > For some reason the file /etc/sudoer.d/ciphermail was lost during the  
> > upgrade. After recreating it, the problem was solved.
> > 
> > Here's the first part of the mail.conf, presuming that the info you  
> > need.
> > 
> > # setting starting with djigzo\_ will be overwritten when applying the  
> > MTA settings  
> > djigzo\_myhostname = ciphermail.example.com  
> > djigzo\_mydestination =  
> > djigzo\_mynetworks = 192.168.1.0/24  
> > djigzo\_relayhost = mail2.example.com  
> > djigzo\_relayhost\_mx\_lookup =  
> > djigzo\_relayhost\_port = 25  
> > djigzo\_relay\_domains = example.com, example.nl, example.net  
> > djigzo\_before\_filter\_message\_size\_limit = 102400000  
> > djigzo\_after\_filter\_message\_size\_limit = 512000000  
> > djigzo\_mailbox\_size\_limit = 512000000  
> > djigzo\_smtp\_helo\_name =  
> > djigzo\_relay\_transport\_host = mail.example.com  
> > djigzo\_relay\_transport\_host\_mx\_lookup =  
> > djigzo\_relay\_transport\_host\_port = 25  
> > djigzo\_reject\_unverified\_recipient =  
> > djigzo\_unverified\_recipient\_reject\_code = 450  
> > djigzo\_parent\_domain\_matches\_subdomains =  
> > djigzo\_rbl\_clients =
> > 
> > ---  
> > Groetjes,
> > 
> > Arie
> > 
> > Martijn Brinkers via Users schreef op 27-08-2017 18:14:
> > 
> > > On 27-08-17 00:39, Arie Koppelaar via Users wrote:
> > > 
> > > > After upgrading from 3.1.1 to 3.2.7 a couple of things went wrong.  
> > > > - From the webinterface menu: Admin/MTA/config - The following error  
> > > > appeared:  
> > > > An unexpected application exception has occurred.
> > > > 
> > > > Render queue error in  
> > > > BeforeRenderTemplate[admin/mta/Config:relaydomains]: Failure reading  
> > > > parameter 'model' of component admin/mta/Config:relaydomains:  
> > > > ProcessException: Error running  
> > > > [/usr/share/djigzo/scripts/execute-script.sh,postfix-main-config,-g].  
> > > > exit value: 1 (1), Class: class mitm.common.util.ProcessException
> > > 
> > > This error is shown when the script cannot be executed. This might be  
> > > cause by some sudoers issue or a script which cannot be executed or  
> > > some config file which cannot be loaded
> > > 
> > > Try to execute the following command
> > > 
> > > sudo -u djigzo /usr/share/djigzo/scripts/execute-script.sh  
> > > postfix-main-config -g
> > > 
> > > It should only ask for your password (for sudo) and not for the  
> > > password of the djigzo user. The command should return the postfix  
> > > main config file and execute without any errors.
> > > 
> > > > - When restarting postfix from the Bash shell, the following error  
> > > > appears:  
> > > > /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter:  
> > > > djigzo\_after\_filter\_message\_size\_limit=512000000
> > > 
> > > This is a warning from Postfix. In a default CipherMail Postfix config  
> > > this parameter should be used. The warning is just a warning. Postfix  
> > > should still be able to run. It could be that you modified the main  
> > > config and that this parameter is not used (hence the warning). Can  
> > > you show you postfix main config?
> > > 
> > > Kind regards,
> > > 
> > > Martijn Brinkers
> > 
> > \_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_  
> > Users mailing list  
> > Users(a)lists.djigzo.com  
> > [https://lists.djigzo.com/lists/listinfo/users](https://lists.djigzo.com/lists/listinfo/users)

---

<div class="post-metadata">

**Author:** ![martijn](https://dub1.discourse-cdn.com/flex017/user_avatar/community.ciphermail.com/martijn/32/127_2.png) [@martijn](https://community.ciphermail.com/u/martijn)\
**Post date:** [August 28, 2017, 8:37pm UTC](https://community.ciphermail.com/t/upgrade-error/572/5 "2017-08-28T20:37:21Z")

</div>

> The difference turned out to be the rule (in the latest appliance version):  
> message\_size\_limit = ${djigzo\_after\_filter\_message\_size\_limit}  
> of the file main.cf, rule 71

The line message\_size\_limit = ${djigzo\_after\_filter\_message\_size\_limit}  
was already part of main.cf from the first release.

Not sure why this was different in your case. Perhaps some postfix  
upgrade script changed it...

Did it work after you set message\_size\_limit to?:

message\_size\_limit = ${djigzo\_after\_filter\_message\_size\_limit}

Kind regards,

Martijn Brinkers

> **···**
>
> On 28-08-17 21:14, Arie Koppelaar wrote:
> 
> > Arie Koppelaar via Users schreef op 27-08-2017 18:37:
> > 
> > > Thanks for your reply. Your remark about the sudo rights was spot on.  
> > > For some reason the file /etc/sudoer.d/ciphermail was lost during the  
> > > upgrade. After recreating it, the problem was solved.
> > > 
> > > Here's the first part of the mail.conf, presuming that the info you need.
> > > 
> > > # setting starting with djigzo\_ will be overwritten when applying the  
> > > MTA settings  
> > > djigzo\_myhostname = ciphermail.example.com  
> > > djigzo\_mydestination =  
> > > djigzo\_mynetworks = 192.168.1.0/24  
> > > djigzo\_relayhost = mail2.example.com  
> > > djigzo\_relayhost\_mx\_lookup =  
> > > djigzo\_relayhost\_port = 25  
> > > djigzo\_relay\_domains = example.com, example.nl, example.net  
> > > djigzo\_before\_filter\_message\_size\_limit = 102400000  
> > > djigzo\_after\_filter\_message\_size\_limit = 512000000  
> > > djigzo\_mailbox\_size\_limit = 512000000  
> > > djigzo\_smtp\_helo\_name =  
> > > djigzo\_relay\_transport\_host = mail.example.com  
> > > djigzo\_relay\_transport\_host\_mx\_lookup =  
> > > djigzo\_relay\_transport\_host\_port = 25  
> > > djigzo\_reject\_unverified\_recipient =  
> > > djigzo\_unverified\_recipient\_reject\_code = 450  
> > > djigzo\_parent\_domain\_matches\_subdomains =  
> > > djigzo\_rbl\_clients =
> > > 
> > > ---  
> > > Groetjes,
> > > 
> > > Arie
> > > 
> > > Martijn Brinkers via Users schreef op 27-08-2017 18:14:
> > > 
> > > > On 27-08-17 00:39, Arie Koppelaar via Users wrote:
> > > > 
> > > > > After upgrading from 3.1.1 to 3.2.7 a couple of things went wrong.  
> > > > > - From the webinterface menu: Admin/MTA/config - The following error  
> > > > > appeared:  
> > > > > An unexpected application exception has occurred.
> > > > > 
> > > > > Render queue error in  
> > > > > BeforeRenderTemplate[admin/mta/Config:relaydomains]: Failure reading  
> > > > > parameter 'model' of component admin/mta/Config:relaydomains:  
> > > > > ProcessException: Error running  
> > > > > [/usr/share/djigzo/scripts/execute-script.sh,postfix-main-config,-g]. exit  
> > > > > value: 1 (1), Class: class mitm.common.util.ProcessException
> > > > 
> > > > This error is shown when the script cannot be executed. This might be  
> > > > cause by some sudoers issue or a script which cannot be executed or  
> > > > some config file which cannot be loaded
> > > > 
> > > > Try to execute the following command
> > > > 
> > > > sudo -u djigzo /usr/share/djigzo/scripts/execute-script.sh  
> > > > postfix-main-config -g
> > > > 
> > > > It should only ask for your password (for sudo) and not for the  
> > > > password of the djigzo user. The command should return the postfix  
> > > > main config file and execute without any errors.
> > > > 
> > > > > - When restarting postfix from the Bash shell, the following error  
> > > > > appears:  
> > > > > /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter:  
> > > > > djigzo\_after\_filter\_message\_size\_limit=512000000
> > > > 
> > > > This is a warning from Postfix. In a default CipherMail Postfix config  
> > > > this parameter should be used. The warning is just a warning. Postfix  
> > > > should still be able to run. It could be that you modified the main  
> > > > config and that this parameter is not used (hence the warning). Can  
> > > > you show you postfix main config?
> > > > 
> > > > Kind regards,
> > > > 
> > > > Martijn Brinkers
> > > 
> > > \_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_  
> > > Users mailing list  
> > > Users(a)lists.djigzo.com  
> > > [https://lists.djigzo.com/lists/listinfo/users](https://lists.djigzo.com/lists/listinfo/users)
> 
> --  
> CipherMail email encryption
> 
> Email encryption with support for S/MIME, OpenPGP, PDF encryption and  
> secure webmail pull.
> 
> > **[CipherMail email encryption and digital signatures](https://www.ciphermail.com)**
> >
> > Easy to use server-side email encryption for automatic encryption and digital signing of email.
> 
> Twitter: [http://twitter.com/CipherMail](http://twitter.com/CipherMail)

---

<div class="post-metadata">

**Author:** ![Arie\_Koppelaar](https://avatars.discourse-cdn.com/v4/letter/a/e19adc/32.png) [@Arie\_Koppelaar](https://community.ciphermail.com/u/Arie_Koppelaar)\
**Post date:** [August 29, 2017, 6:44am UTC](https://community.ciphermail.com/t/upgrade-error/572/6 "2017-08-29T06:44:07Z")

</div>

For some reason the rule disappeared from the main.cf. After adding it  
again the problem was solved.

Best regards and thanks again for the support.

Martijn Brinkers schreef op 28-08-2017 22:37:

> **···**
>
> > On 28-08-17 21:14, Arie Koppelaar wrote:
> > 
> > > The difference turned out to be the rule (in the latest appliance  
> > > version):  
> > > message\_size\_limit = ${djigzo\_after\_filter\_message\_size\_limit}  
> > > of the file main.cf, rule 71
> > 
> > The line message\_size\_limit =  
> > ${djigzo\_after\_filter\_message\_size\_limit} was already part of main.cf  
> > from the first release.
> > 
> > Not sure why this was different in your case. Perhaps some postfix  
> > upgrade script changed it...
> > 
> > Did it work after you set message\_size\_limit to?:
> > 
> > message\_size\_limit = ${djigzo\_after\_filter\_message\_size\_limit}
> > 
> > Kind regards,
> > 
> > Martijn Brinkers
> > 
> > > Arie Koppelaar via Users schreef op 27-08-2017 18:37:
> > > 
> > > > Thanks for your reply. Your remark about the sudo rights was spot on.  
> > > > For some reason the file /etc/sudoer.d/ciphermail was lost during the  
> > > > upgrade. After recreating it, the problem was solved.
> > > > 
> > > > Here's the first part of the mail.conf, presuming that the info you  
> > > > need.
> > > > 
> > > > # setting starting with djigzo\_ will be overwritten when applying the  
> > > > MTA settings  
> > > > djigzo\_myhostname = ciphermail.example.com  
> > > > djigzo\_mydestination =  
> > > > djigzo\_mynetworks = 192.168.1.0/24  
> > > > djigzo\_relayhost = mail2.example.com  
> > > > djigzo\_relayhost\_mx\_lookup =  
> > > > djigzo\_relayhost\_port = 25  
> > > > djigzo\_relay\_domains = example.com, example.nl, example.net  
> > > > djigzo\_before\_filter\_message\_size\_limit = 102400000  
> > > > djigzo\_after\_filter\_message\_size\_limit = 512000000  
> > > > djigzo\_mailbox\_size\_limit = 512000000  
> > > > djigzo\_smtp\_helo\_name =  
> > > > djigzo\_relay\_transport\_host = mail.example.com  
> > > > djigzo\_relay\_transport\_host\_mx\_lookup =  
> > > > djigzo\_relay\_transport\_host\_port = 25  
> > > > djigzo\_reject\_unverified\_recipient =  
> > > > djigzo\_unverified\_recipient\_reject\_code = 450  
> > > > djigzo\_parent\_domain\_matches\_subdomains =  
> > > > djigzo\_rbl\_clients =
> > > > 
> > > > ---  
> > > > Groetjes,
> > > > 
> > > > Arie
> > > > 
> > > > Martijn Brinkers via Users schreef op 27-08-2017 18:14:
> > > > 
> > > > > On 27-08-17 00:39, Arie Koppelaar via Users wrote:
> > > > > 
> > > > > > After upgrading from 3.1.1 to 3.2.7 a couple of things went wrong.  
> > > > > > - From the webinterface menu: Admin/MTA/config - The following  
> > > > > > error appeared:  
> > > > > > An unexpected application exception has occurred.
> > > > > > 
> > > > > > Render queue error in  
> > > > > > BeforeRenderTemplate[admin/mta/Config:relaydomains]: Failure  
> > > > > > reading parameter 'model' of component  
> > > > > > admin/mta/Config:relaydomains: ProcessException: Error running  
> > > > > > [/usr/share/djigzo/scripts/execute-script.sh,postfix-main-config,-g].  
> > > > > > exit value: 1 (1), Class: class mitm.common.util.ProcessException
> > > > > 
> > > > > This error is shown when the script cannot be executed. This might  
> > > > > be  
> > > > > cause by some sudoers issue or a script which cannot be executed or  
> > > > > some config file which cannot be loaded
> > > > > 
> > > > > Try to execute the following command
> > > > > 
> > > > > sudo -u djigzo /usr/share/djigzo/scripts/execute-script.sh  
> > > > > postfix-main-config -g
> > > > > 
> > > > > It should only ask for your password (for sudo) and not for the  
> > > > > password of the djigzo user. The command should return the postfix  
> > > > > main config file and execute without any errors.
> > > > > 
> > > > > > - When restarting postfix from the Bash shell, the following error  
> > > > > > appears:  
> > > > > > /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused  
> > > > > > parameter: djigzo\_after\_filter\_message\_size\_limit=512000000
> > > > > 
> > > > > This is a warning from Postfix. In a default CipherMail Postfix  
> > > > > config  
> > > > > this parameter should be used. The warning is just a warning.  
> > > > > Postfix  
> > > > > should still be able to run. It could be that you modified the main  
> > > > > config and that this parameter is not used (hence the warning). Can  
> > > > > you show you postfix main config?
> > > > > 
> > > > > Kind regards,
> > > > > 
> > > > > Martijn Brinkers
> > > > 
> > > > \_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_  
> > > > Users mailing list  
> > > > Users(a)lists.djigzo.com  
> > > > [https://lists.djigzo.com/lists/listinfo/users](https://lists.djigzo.com/lists/listinfo/users)
